$re = '/android(?!.*mobile)/';
$str = 'android should be matched
android should not match on a mobile';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);