re = /android(?!.*mobile)/
str = 'android should be matched
android should not match on a mobile'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end