#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(DTP\*431.*?)REF\*6R"
Local $sString = "DTP*431*D8*20150101~" & @CRLF & _
"[variable text in between]" & @CRLF & _
"LX*1~" & @CRLF & _
"DTP*472*RD8*20150102-20150102~" & @CRLF & _
"REF*6R*[more information]~" & @CRLF & _
"[variable text in between]" & @CRLF & _
"DTP*431*D8*20141231~" & @CRLF & _
"[variable text in between]" & @CRLF & _
"LX*1~" & @CRLF & _
"DTP*472*RD8*20150101-20150101~" & @CRLF & _
"REF*6R*[more information]~"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")