import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(DTP\\*431.*?)REF\\*6R";
final String string = "DTP*431*D8*20150101~\n"
+ "[variable text in between]\n"
+ "LX*1~\n"
+ "DTP*472*RD8*20150102-20150102~\n"
+ "REF*6R*[more information]~\n"
+ "[variable text in between]\n"
+ "DTP*431*D8*20141231~\n"
+ "[variable text in between]\n"
+ "LX*1~\n"
+ "DTP*472*RD8*20150101-20150101~\n"
+ "REF*6R*[more information]~";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}