re = /(DTP\*431.*?)REF\*6R/
str = 'DTP*431*D8*20150101~
[variable text in between]
LX*1~
DTP*472*RD8*20150102-20150102~
REF*6R*[more information]~
[variable text in between]
DTP*431*D8*20141231~
[variable text in between]
LX*1~
DTP*472*RD8*20150101-20150101~
REF*6R*[more information]~'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end