import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<number>[0-9]+)\\.(?<surname>[a-z\\s]+)/(?<firstname>[a-z]+(?:\\s+[a-z]+)*?)(?:\\s+(?<title>m(?:rs?|iss|str)))?(?:\\s+(?<dob>[0-9]{2}[a-z]{3}))?(?=\\s[0-9]+\\.|$)";
final String string = "1.uzamaki/narutomr 20mar\n"
+ "2.hyuga/hinata mrs 13apr\n"
+ "3.haruno/sakuramiss 25nov\n"
+ "4.uchiha/sasuke mstr\n"
+ "5.uchiha/itachi akatsuki mr 12feb\n"
+ "6.lee/rock 23jun\n"
+ "7.hatake/kakashi mr 30oct 8.sarutobi/hiruzen mr 31dec";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}