$re = '~(?<number>[0-9]+)\.(?<surname>[a-z\s]+)/(?<firstname>[a-z]+(?:\s+[a-z]+)*?)(?:\s+(?<title>m(?:rs?|iss|str)))?(?:\s+(?<dob>[0-9]{2}[a-z]{3}))?(?=\s[0-9]+\.|$)~';
$str = '1.uzamaki/narutomr 20mar
2.hyuga/hinata mrs 13apr
3.haruno/sakuramiss 25nov
4.uchiha/sasuke mstr
5.uchiha/itachi akatsuki mr 12feb
6.lee/rock 23jun
7.hatake/kakashi mr 30oct 8.sarutobi/hiruzen mr 31dec';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);