import re
regex = re.compile(r"(?<number>[0-9]+)\.(?<surname>[a-z\s]+)/(?<firstname>[a-z]+(?:\s+[a-z]+)*?)(?:\s+(?<title>m(?:rs?|iss|str)))?(?:\s+(?<dob>[0-9]{2}[a-z]{3}))?(?=\s[0-9]+\.|$)")
test_str = ("1.uzamaki/narutomr 20mar\n"
"2.hyuga/hinata mrs 13apr\n"
"3.haruno/sakuramiss 25nov\n"
"4.uchiha/sasuke mstr\n"
"5.uchiha/itachi akatsuki mr 12feb\n"
"6.lee/rock 23jun\n"
"7.hatake/kakashi mr 30oct 8.sarutobi/hiruzen mr 31dec")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")