using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(x1)[\s\S]*?(x2)";
string input = @"x1..........x2.............x8................x2";
RegexOptions options = RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}