package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(x1)[\s\S]*?(x2)`)
var str = `x1..........x2.............x8................x2`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}