$re = '/(x1)[\s\S]*?(x2)/u';
$str = 'x1..........x2.............x8................x2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);