using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^.*[A-Z]+.*$)(?=^.*[a-z]+.*$)(?=^.*[0-9]+.*$)^[0-9A-z]{8,}$";
string input = @"123aWAAasd11aa4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}