$re = '/(?=^.*[A-Z]+.*$)(?=^.*[a-z]+.*$)(?=^.*[0-9]+.*$)^[0-9A-z]{8,}$/m';
$str = '123aWAAasd11aa4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);