re = /(?=^.*[A-Z]+.*$)(?=^.*[a-z]+.*$)(?=^.*[0-9]+.*$)^[0-9A-z]{8,}$/m
str = '123aWAAasd11aa4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end