using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?!data:).*)";
string input = @"data:text/plain;base64,SGVsbG8sIFdvcmxkIQ%3D%3D";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}