const regex = /((?!data:).*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?!data:).*)', '')
const str = `data:text/plain;base64,SGVsbG8sIFdvcmxkIQ%3D%3D`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}