$re = '/((?!data:).*)/';
$str = 'data:text/plain;base64,SGVsbG8sIFdvcmxkIQ%3D%3D';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);