package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:a|the|one)\s+(?:reason|reasons)\s+(?:for|of)`)
var str = `a reason of
the reason for
one reason for
reason for`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}