re = /(?:a|the|one)\s+(?:reason|reasons)\s+(?:for|of)/m
str = 'a reason of
the reason for
one reason for
reason for'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end