$re = '/(?:a|the|one)\s+(?:reason|reasons)\s+(?:for|of)/m';
$str = 'a reason of
the reason for
one reason for
reason for';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);