#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!.*[\W_]$)(?=^.{3,25}$).*"
Local $sString = "abc#123" & @CRLF & _
"a%scsd" & @CRLF & _
"abc453&" & @CRLF & _
"ab" & @CRLF & _
"123%" & @CRLF & _
"abacvfrdfrgthgfrthgf222222" & @CRLF & _
"abacvfrdfrgthgfrthgf22222"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")