const regex = /(?!.*[\W_]$)(?=^.{3,25}$).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!.*[\\W_]$)(?=^.{3,25}$).*', 'gm')
const str = `abc#123
a%scsd
abc453&
ab
123%
abacvfrdfrgthgfrthgf222222
abacvfrdfrgthgfrthgf22222`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}