re = /(?!.*[\W_]$)(?=^.{3,25}$).*/m
str = 'abc#123
a%scsd
abc453&
ab
123%
abacvfrdfrgthgfrthgf222222
abacvfrdfrgthgfrthgf22222'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end