import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\w-]{1,63}?\\.)*([a-zA-Z0-9-]{1,63}\\.)([a-zA-Z0-9-]{2,63})$";
final String string = "this_is.ok.com\n"
+ "this_is.another_valid.domain.com\n\n"
+ "this_one.is_not_ok.com\n"
+ "not_ok.com\n"
+ "also.not_ok";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}