$re = '/^([\w-]{1,63}?\.)*([a-zA-Z0-9-]{1,63}\.)([a-zA-Z0-9-]{2,63})$/m';
$str = 'this_is.ok.com
this_is.another_valid.domain.com
this_one.is_not_ok.com
not_ok.com
also.not_ok';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);