import re
regex = re.compile(r"^([\w-]{1,63}?\.)*([a-zA-Z0-9-]{1,63}\.)([a-zA-Z0-9-]{2,63})$", flags=re.MULTILINE)
test_str = ("this_is.ok.com\n"
"this_is.another_valid.domain.com\n\n"
"this_one.is_not_ok.com\n"
"not_ok.com\n"
"also.not_ok")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")