using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\<)(.*?)(?=\>)";
string input = @"<http://192.168.1.10:8080/longUrl>; rel=""recording-session"",
<http://192.168.1.10:8080/realLongUrl>; rel=""h264-session-sdp"",
<http://192.168.1.10:8080/realLongDifferentUrl>; rel=""h264-session-sdp"",
<rtp://239.1.1.18:5006>; rel=""destination-high"",
<rtp://239.1.1.17:5006>; rel=""destination-low""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}