import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\<)(.*?)(?=\\>)";
final String string = "<http://192.168.1.10:8080/longUrl>; rel=\"recording-session\",\n"
+ "<http://192.168.1.10:8080/realLongUrl>; rel=\"h264-session-sdp\", \n"
+ "<http://192.168.1.10:8080/realLongDifferentUrl>; rel=\"h264-session-sdp\", \n"
+ "<rtp://239.1.1.18:5006>; rel=\"destination-high\", \n"
+ "<rtp://239.1.1.17:5006>; rel=\"destination-low\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}