const regex = /^(?:(?=.*\b5[15]00\b)[0-9]{2,}\\[0-9]{2}-[0-9]{4}-[0-9]{3}-|(?!.*\b5[15]00\b)[0-9]{2,}\\[0-9]{2}-[0-9]{4}-[0-9]{3}-[0-9]{2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?=.*\\b5[15]00\\b)[0-9]{2,}\\\\[0-9]{2}-[0-9]{4}-[0-9]{3}-|(?!.*\\b5[15]00\\b)[0-9]{2,}\\\\[0-9]{2}-[0-9]{4}-[0-9]{3}-[0-9]{2})$', 'gm')
const str = `01\\01-5500-000-
01\\01-5000-000-00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}