$re = '/^(?:(?=.*\b5[15]00\b)[0-9]{2,}\\\\[0-9]{2}-[0-9]{4}-[0-9]{3}-|(?!.*\b5[15]00\b)[0-9]{2,}\\\\[0-9]{2}-[0-9]{4}-[0-9]{3}-[0-9]{2})$/m';
$str = '01\\01-5500-000-
01\\01-5000-000-00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);