import re
regex = re.compile(r"^\d.*?\b\d{5}$", flags=re.MULTILINE | re.DOTALL)
test_str = ("asf aSD ikugfr jddc ghddfj gjn dfxg \n"
"sdgal fghfh 16 rgjodrisgj frth fghsdf,\n"
"dfghdf dfhgdh gho h ghdof 67676\n\n"
"szdgfads\n"
"2 adf dojosd hsh fghs, \n"
"zfgdf dhgdzsfb dfgdz,\n"
"dzgdzfvg 47564\n\n"
"asdgasdg asdg\n"
"4334 ersga errr ertgerfd ertera erers qereadf erfesfdc wefadfe, \n"
"sfsdgfg-43647\n\n"
"2 adf dojosd hsh fghs, \n"
"zfgdf dhgdzsfb dfgdz,\n"
"dzgdzfvg and more than 5 digits here 11147564")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")