package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^ ]+[ ]+[^ ]+)[ ]`)
var str = `get close to,be next to,follow in sequence or along designated route/ direction`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}