package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-z]+?\.([a-z]+)?\.`)
var str = `www.whatever.com
www.iam.com.uk
mobile.who.com.us
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}