re = /[a-z]+?\.([a-z]+)?\./
str = 'www.whatever.com
www.iam.com.uk
mobile.who.com.us
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end