$re = '/[a-z]+?\.([a-z]+)?\./';
$str = 'www.whatever.com
www.iam.com.uk
mobile.who.com.us
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);