import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:[^+\\n]*\\+){7})\\d{8}(?=\\+(?:\\d{8})?\\+)";
final String string = "UNA:+,? '\n"
+ "UNB+UNOC:3+000000000+000000000+20190801:1115+00001+DDMP190001'\n"
+ "UNH+00001+BRKE:01+00+0'\n"
+ "INV+ED Format 1+Brustkrebs+19880117+E000000001+20080702+++1+0'\n"
+ "FAL+087897044+0000000++Trägername+000000000+0+20080702++1+++J+N+N+N+N+N+++0'\n"
+ "INL+181095200+385762115+++0'\n"
+ "BEE+20080702++++0'\n"
+ "BAA+++J+J++++++J+++++++J++0'\n"
+ "BBA++++++++J++++++J+J++++++J+++++J+++J+J++++++++J+0'\n"
+ "BHP+J+++++J+++++J+++++0'\n"
+ "BLA+++J+++++++++0'\n"
+ "BFA++++++++++++J++0'\n"
+ "BSA++J+++J+J+++0'\n"
+ "BAT+20190801+0'\n"
+ "DAT+20080702++++0'\n"
+ "UNT+000014+00001'\n"
+ "UNZ+00001+00001'\n\n";
final String subst = "\\g<1>20200101";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}