$re = '/^((?:[^+\n]*\+){7})\d{8}(?=\+(?:\d{8})?\+)/m';
$str = 'UNA:+,? \'
UNB+UNOC:3+000000000+000000000+20190801:1115+00001+DDMP190001\'
UNH+00001+BRKE:01+00+0\'
INV+ED Format 1+Brustkrebs+19880117+E000000001+20080702+++1+0\'
FAL+087897044+0000000++Trägername+000000000+0+20080702++1+++J+N+N+N+N+N+++0\'
INL+181095200+385762115+++0\'
BEE+20080702++++0\'
BAA+++J+J++++++J+++++++J++0\'
BBA++++++++J++++++J+J++++++J+++++J+++J+J++++++++J+0\'
BHP+J+++++J+++++J+++++0\'
BLA+++J+++++++++0\'
BFA++++++++++++J++0\'
BSA++J+++J+J+++0\'
BAT+20190801+0\'
DAT+20080702++++0\'
UNT+000014+00001\'
UNZ+00001+00001\'
';
$subst = "\g<1>20200101";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;