package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(8 6)\d{2} \d{2} \d{3}`)
var str = `8 650 51 210 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}