$re = '/(8 6)\d{2} \d{2} \d{3}/';
$str = '8 650 51 210 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);