package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<[^>]+>(*SKIP)(*FAIL)|([\w']+)`)
var str = `Non ! Non ! Je ne veux pas d'un éléphant dans un boa.<br>
<p> Un boa c'est très dangereux, et un éléphant élévé c'est très encombrant. Chez moi c'est tout petit. J'ai besoin d'un mouton. Dessine-moi un mouton.
</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}