// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)<[^>]+>(*SKIP)(*FAIL)|([\w']+)").unwrap();
let string = "Non ! Non ! Je ne veux pas d'un éléphant dans un boa.<br>
<p> Un boa c'est très dangereux, et un éléphant élévé c'est très encombrant. Chez moi c'est tout petit. J'ai besoin d'un mouton. Dessine-moi un mouton.
</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}