re = /<[^>]+>(*SKIP)(*FAIL)|([\w']+)/
str = 'Non ! Non ! Je ne veux pas d\'un éléphant dans un boa.<br>
<p> Un boa c\'est très dangereux, et un éléphant élévé c\'est très encombrant. Chez moi c\'est tout petit. J\'ai besoin d\'un mouton. Dessine-moi un mouton.
</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end