using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+\S+$";
string substitution = @"";
string input = @"Peter Eli Smith
Vanessa Mary Ellen
Raul Gonzales
Kristine S Lee";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}