// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s+\S+$").unwrap();
let string = "Peter Eli Smith
Vanessa Mary Ellen
Raul Gonzales
Kristine S Lee";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}