$re = '/\s+\S+$/m';
$str = 'Peter Eli Smith
Vanessa Mary Ellen
Raul Gonzales
Kristine S Lee';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;