#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=(?:\d|(?<=\d)[_\W]\d){4,5})\d|(?<=(?<!^)\G)\d|(?<=\d)[_\W]\d"
Local $sString = "any text 000 00 more texts" will become "any text ***** more texts"..notice that the space is removed" & @CRLF & _
"" & @CRLF & _
""any text 000 00 more texts 00" will become "any text ***** more texts 00"" & @CRLF & _
"" & @CRLF & _
""any text 000 00 more texts 00 00" will become "any text ***** more texts ****"" & @CRLF & _
""any text 00-00 more texts 00_00" will become "any text **** more texts ****""
Local $sSubst = "*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)