# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=(?:\d|(?<=\d)[_\W]\d){4,5})\d|(?<=(?<!^)\G)\d|(?<=\d)[_\W]\d"
test_str = ("any text 000 00 more texts\" will become \"any text ***** more texts\"..notice that the space is removed\n\n"
"\"any text 000 00 more texts 00\" will become \"any text ***** more texts 00\"\n\n"
"\"any text 000 00 more texts 00 00\" will become \"any text ***** more texts ****\"\n"
"\"any text 00-00 more texts 00_00\" will become \"any text **** more texts ****\"")
subst = "*"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.