using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?:\d|(?<=\d)[_\W]\d){4,5})\d|(?<=(?<!^)\G)\d|(?<=\d)[_\W]\d";
string substitution = @"*";
string input = @"any text 000 00 more texts"" will become ""any text ***** more texts""..notice that the space is removed
""any text 000 00 more texts 00"" will become ""any text ***** more texts 00""
""any text 000 00 more texts 00 00"" will become ""any text ***** more texts ****""
""any text 00-00 more texts 00_00"" will become ""any text **** more texts ****""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}