package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/?t?e?s?t?/(\w+)+`)
var str = `/test/abc/123/klm/534/uuuu/342342`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}