$re = '//?t?e?s?t?/(\w+)+/';
$str = '/test/abc/123/klm/534/uuuu/342342';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);